Функция СЧEТЕСЛИ в Excel

Очень удобным и полезным инструментом для себя считаю функцию  СЧЕТЕСЛИ() в Excel.

Суть формулы заключается в следующем:

  • Если условие, которое вы выбрали для функции, удовлетворительно в данной ячейке, то Excel считает эту ячейку как 1.

Как правильно пользоваться функцией СЧЕТЕСЛИ в Excel (англ. COUNTIF), а также примеры вы найдёте далее.

Зачем нужна функцией СЧЕТЕСЛИ в Excel

Лично я использую функцию СЧЕТЕСЛИ в Excel (COUNTIF) когда мне необходимо убедиться, что число или текст в моей таблице не повторяется, т.е. содержится только в 1ом ряду таблицы.

Пример использования функции СЧЕТЕСЛИ в EXCEL №1

Пример использования функции Excel СЧЁТЕСЛИ (COUNTIF)

Как видим, у нас таблица с повторяющимся номером № 125. Чтобы это выяснить, я использовал функцию СЧЁТЕСЛИ.

Какие аргументы (части) включаются в функцию СЧЕТЕСЛИ в Excel

=СЧЁТЕСЛИ(диапазон;критерий)

  • диапазон = колонка со значениями
    Здесь выбираем нашу колонку. По вашему критерию СЧЁТЕСЛИ посчитает каждую ячейку из колонки. Каждая ячейка будет считаться как единица (1).
  • критерий = фильтр
    Критерий это фильтр, согласно которому функция проверяет надо ли считать ячейку или нет.

Пример использования функции СЧЕТЕСЛИ в Excel №2

Ваш критерий = «яблоко».
В каждой ячейке колонки (диапазона) напечатано слово яблоко. Функция посчитает все ячейки из этой колонки.
4 ячейки с яблоком. Результат функции = 4.
=СЧЁТЕСЛИ($A$2:$A$5;»яблоко»)
Пример 1 - СЧЕТЕСЛИ для подсчёта количества
Пример 1 - таблица с использованием функции СЧЕТЕСЛИ
Примечание: если вы хотите выбрать такой критерий как слово (яблоко), вам необходимо ставить его в кавычки «яблоко».

Как пользоваться функцией СЧЕТЕСЛИ в Excel

Чтобы рассмотреть пошаговую инструкцию по тому как использовать функцию СЧЕТЕСЛИ, надо взять пример с необходимостью решить проблему. Поставив конкретную цель, мы сможем понять какую формулу нам взять и зачем.

Пример использования функции СЧЕТЕСЛИ в Excel №3: Таблица «Товары»

Таблица для примера использования функции СЧЕТЕСЛИ

Цель: найти неуникальные записи в таблице
Ожидаемый результат: в новой добавленной колонке № 3 для всех неуникальных записей будет число > 1.

Решение нашей задачи

Добавляем новую колонку для функции СЧЕТЕСЛИ

  • Добавляем к нашей таблице новую колонку в конце

(если в вашей таблице много колонок, можно добавить новую колонку после колонки с номерами, которые мы проверяем)

  1. Теперь стаём в ячейку C2 (в 1ую ячейку новой колонки) и добавляем нашу функцию.
    Печатаем:
    =СЧЁТЕСЛИ(
  2. Левой кнопкой мышки выбираем диапазон, т.е. 1ую колонку, получаем:
    =СЧЁТЕСЛИ(A2:A7
  3. Ставим точку с запятой (на клавиатуре)
    =СЧЁТЕСЛИ(A2:A7;
  4. Выбираем левой кнопкой мыши 1ую ячейку из 1ой колонки «№»
    =СЧЁТЕСЛИ(A2:A7;A2
  5. Закрываем скобку )
    =СЧЁТЕСЛИ(A2:A7;A2)

Примечание: если вы всё правильно написали, скобку закрывать необязательно, нажмите ENTER и Excel сам поставит скобку.

Как зафиксировать диапазон (важно)

Для того, чтобы формула работала правильно, необходимо зафиксировать ссылку.
Пока ссылка незафиксирована при протягивании, она сбивается.

Поэтому, если вы протянете формулу вниз, вы получите неверные данные.

Примечание: важно помнить, если вы нашли ошибку, то это ошибка в формуле, Excel не ошибается в подсчётах.

Для того, чтобы ваша функция была правильной вам необходимо зафиксировать диапазон, т.е. сделать ссылку на диапазон абсолютной. Есть 2 способа.

Способ № 1 Фиксируем диапазон вручную

Для этого вы можете вручную поставить в каждую ячейку диапазона доллар $ перед буквами и цифрами в диапазоне — $A$2.

Способ № 2 Фиксируем диапазон с помощью F4

Сделать диапазон абсолютным

Знак Excel - Вставить функциюШаг 1: Становимся в ячейку с формулой
Шаг 2: Ставим курсор на верхней панели после скобок
Шаг 3: Нажимаем на высветившийся диапазон
Шаг 3: Нажимаем на клавиатуре F4

Всё , теперь вы протяните формулу заново, чтобы она обновилась во всех ячейках. Теперь готово.

Вышеперечисленные примеры в Excel:
Скачать примеры функции СЧЕТЕСЛИСкачать примеры функции СЧЕТЕСЛИ

Если вас интересует ещё одна важная формула Excel, то вас может заинтересовать следующая статья: Функция VLOOKUP (ВПР)

Добавить комментарий